Sapphire Plug-ins for After Effects

Sapphire Plug-ins v11.01 for After Effects, General User Info



What's New In This Version

New Effects:

  • S_VignetteMocha creates a vignette using a Mocha-tracked mask as the shape of the vignette. All the options of regular Vignette are available.

New Features:

  • Mocha tracking and masking is added to most effects
    • Exceptions: Transitions, Z effects, Retime, RackDfComp, RepairFrames
  • Many more effects have mask inputs now (over 80 more). Almost all the ones that didn't before, where it makes sense. Some examples: Aurora, Cartoon, Clouds, DigitalDamage, and Layer.
  • S_Grunge now has a Crop Grunge to Mask parameter.
  • Glint, GlintRainbow and Glare can now select luma, color or alpha for the mask using new Mask Type parameter.
  • S_Swish3D's default wrap behavior has been changed to Repeat.
  • Loading a single-effect preset into Builder or S_Effect will now automatically connect the Mask node to the Mask input of the effect node.

New in 11.01:

  1. Fixed a bug that changed the rendered output of all Glows (e.g. S_Glow, S_GlowEdges, etc.) and Sparkles (both S_Sparkles and S_SparklesColor) between v10 and v11.0 if the user provided a color mask. These effects are now compatible with v10's output but the output will change relative to v11.0! To get the output from v11.0 back, apply S_Monochrome to the mask before passing it to the effect.
    • Note: This also affects any S_Effect presets made with v11.0 using Glows or Sparkles. Please check your presets for Glows or Sparkles and update with S_Monochrome if needed for the desired behavior.
  2. VignetteMocha mode of S_Vignette now starts with an empty Mocha project. In this case VignetteMocha will use a circular mask until a Mocha Mask is set. This circular mask will not show up in the Mocha UI.
  3. Mocha help link now points to Sapphire Mocha help instead of BCC Mocha help.
  4. Mocha now remembers the previous Open Project and Export Project locations.
  5. Mocha in Sapphire and Mocha in BCC now save preferences and settings separately.
  6. Minor preset improvements.

Loading a Plug-in

Once Sapphire Plug-ins have been installed and the host application has been restarted, the new plug-ins should appear in the host application's effects menu just like any other effects.

To load a plug-in in Adobe After Effects, go to the Effects menu and open one of the Sapphire folders. You can double click on an effect to insert it into your current layer's effects, or drag it onto the desired location in your current layer.


Browsing and Selecting Presets

You can load and save presets for effects using the Load Preset and Save Preset buttons near the top of the effect control window in all Sapphire effects.

Loading:

In the preset browser you'll see all the presets available for the current plug-in, both GenArts-supplied presets and the ones you've created yourself. You can filter by tags on the left side to quickly find the look you're interested in.

The main top window shows the preset on your footage (unless the plug-in can't access the AE layer for some reason, in which case you'll see a poster frame) and various information about the preset.

At the bottom you see all the presets; you can enlarge or shrink them with the slider at the bottom. You can also switch to a table view there, as well as viewing the preset on your source, over black, or over the sample footage. You can also see the source all by itself for comparison.

If you are using the S_Effect plug-in, you can browse all the Sapphire presets at once. See S_Effect for more information.

Saving:

Clicking Save Preset brings up the Save Preset dialog. Here you can name the preset, and add various other information. Particularly important is the tagging system; you can apply as many tags as you want to your presets. You can even create new tags. Tags are grouped into categories, so all the color names appear under Colors, for instance.

You can create new categories as well, by typing into the Category drop-down menu after clicking Add New Tag.... GenArts recommends sticking to the shipped categories when possible, for compatibility. But adding your own tags within categories (new color names, for example) is encouraged.

More Info:

While the preset browser, save dialog, or flare designer are open, the main AE window will be unresponsive. This is normal. Close the preset browser or flare designer and AE will wake up again.

Certain parameters, like Lens Flare hotspot, are not saved in presets; we thought it would be less than useful for the flares to jump around as you load presets.

It may take a few seconds to load the preset browser if a plug-in has many presets. Be patient.


Editing and Designing Lens Flares and other elements

Clicking Edit Lens in LensFlare, or Edit Style in Glare or Flashbulbs, opens up the Lens Flare Designer.

The Flare Designer lets you completely customize a lens flare. You can add or remove elements, copy them, customize how each element looks, and even how it reacts to the center or edge of the image. You can also interactively move the flare around to see how it will look as it moves.

All the panels of the Flare Designer are movable, so you can adjust the user interface itself to suit your work flow. The main panels are the view window, where you see the flare you're working on, the Elements panel which lists all the elements of the flare, and the Properties panel, which lets you adjust the properties of the currently selected element (or elements). There's also a toolbar of element templates at the top.

View Panel

The main view window is where you see how your flare will look; you can click and drag to move the flare around. You can see it over the background or just over black, adjust the gamma, and Solo only the selected elements. Use Plug-in Settings makes the flare designer import the plug-in settings currently active in the host app. If you have that selected, the flare will look the same back in the host app when you're done designing it. On the other hand, if you want to create a "reusable" flare preset, it's probably a good idea to un-check Use Plug-in Settings so the flare will look good with default settings in the plug-in.

Elements Panel

The Elements panel shows you all the elements, with thumbnails. If you mouse over them, an overlay shows where they are in the main view window. When you click on an element to select it, it also flashes brighter in the main window to help you find the element you're looking for. Clicking Identify in the Properties panel does the same flashing.

To add new elements, just click the element template picture in the top toolbar. You can then rename the element, move it in the list by dragging and dropping, or hide it by un-checking the checkbox.

To delete an elements, select it and click the trash can icon at the bottom of the Elements panel, or click Delete. There is full undo, so feel free to experiment!

You can also duplicate an element using standard copy/paste operations, or select it and click the two pages icon at the bottom of the Elements panel. You can then adjust the copy's parameters in the Parameters panel.

The gear-looking element is the "advanced element" type; it has lots of controls and is very customizable, but it's recommended for advanced users only. The other types get you most of the same looks with simpler parameters.

Along with all the standard element types, you can import your own images to use as elements. Click the picture frame to import an image file. The image data will become part of the flare, so it doesn't need to keep a reference to the original file.

To combine two flares into one, or add many elements at once, you can import another flare into your current flare; this will add all the other flare's elements to your current flare. You can also just open that flare, which replaces your current flare with that one. To import and add to your flare, use Insert Flare (down-right pointing arrow in the toolbar), or File... Insert Flare. To import and replace, use Open Flare (folder icon in the toolbar), or use File... Open Flare.

Parameters Panel

The Parameters panel is where you adjust all the details of a single element -- or multiple elements together, if you select multiple elements in the Elements panel. (Use Shift-click or Control-click to select multiple elements.)

There are a few common control types. Sliders with numbers to the left control numeric params; you can drag the slider thumb, but you can also drag in the number text field to increase or decrease the value. You can also click in the number field and type any value you want.

Color controls are just a swatch of color; click to bring up a standard color picker.

Some elements have a Gradient; there's a special gradient control to adjust those. The stops are below the color swatch; you can drag them left and right to move them. Drag down to delete. Click in the color gradient to add a stop there. Control-drag to "stretch" neighboring colors, and shift-drag to push neighboring colors. The triangles above the color gradient allow you to control the interpolation of the colors between stops. Ring Thickness lets you easily turn a spot or fan of rays into a ring; turning Ring Thickness down from 1 hollows out the center. This lets you still have fine control of the colors within the ring, even if it's very thin.

Different element types will have various parameters you can adjust, but here are some common ones:

Position
Where the element occurs, along the line between the hotspot and pivot point. Position 1.0 is at the hotspot, 0.0 is at the pivot. Note that you don't have to stay in that range; you can use any value you like. Bigger than 1 will be past the hotspot, and less than zero will look like a reflection because it's on the other side of the pivot point.
Size
How big the image is.
Rel Width, Rel Height
Use these to squash and stretch.
Rotate
Rotates the element around, in degrees.
There's a Reset button at the bottom of the Parameters panel to reset the current element(s) to all default settings. That's undoable too.

More Information

If you open the flare designer from the plug-in, you can just click OK to close the window when you're done; your current flare will be used in your project and saved with it. But you can do more than that; you can save the flare definition to disk separately, so you can recall it later, or use it in other flares. You can also open the flare designer directly from the Start menu or Applications folder to create flares independent of your host product. In this case, use File...Save Lens As... to save the flare definition. That dialog will allow you to name the lens and tag it so it's easy to find later.

Note that saving a lens this way does not save your plug-in settings; it only saves the lens flare definition itself (the things you can change in the flare designer). You can save a preset in the host application to save everything -- the flare and all the regular plug-in parameters.

While the preset browser, save dialog, or flare designer are open, the main AE window will be unresponsive. This is normal. Close the preset browser or flare designer and AE will wake up again.


Using the Sapphire Effect Builder

Builder lets you design completely new effects by combining several Sapphire effects together. The result is a new effect that does what all the different effects you add to the workspace do, but it can be applied and used as a single effect.

Starting Builder

To use the Effect Builder, apply S_Effect or S_Transition (both in the Sapphire Builder category) to a clip, or between two clips in the case of S_Transition. Then press the Edit Effect button to bring up the Builder interface. Create the effect in the builder interface, then when you return to AE or Premiere your new effect will be there, with all of its published parameters. You can also load effects you've defined before, using the Load Preset button in these effects. The builder interface is composed of several panels, described below.

Panels

The builder interface is where you create and customize your new effect. All the panels are movable and resizable so you can customize the layout for your particular work style.
Components
The Components panel lists all the Sapphire effects. They're listed by category, and you can search for any one you want; you can also organize them alphabetically. To add an effect to your workspace, double-click it or drag it onto a line on the node graph, or onto another node to add it after that one.

The Tools category contains tools that are only available in Builder:

Color
creates a solid color
Composite
a simple premultiplied composite. Use when the foreground clip already has an alpha channel.
Blend
dissolve between two clips using a Matte input. Use when the foreground clip does not have an alpha channel.
Crop
crop to a rectangular area
Cutout
crop input to an arbitrary shape, given by a Matte input. The Matte multiplies with any alpha channel that's already present.
SetAlpha
add an alpha channel to a clip which doesn't have one, and premultiply.
Sticky Note
write notes in the workspace
Preview Window
The preview window is where you see the result of the effect you're creating. It has a play bar so you can see any animation in the nodes you've added. You can also play through transitions if you're using S_Transition.
Node Graph

The Node Graph is where you build the new effect. Processing flows from the Source node to the Result node; you add whatever effects you want in between to build a processing pipeline. Using multi-input effects like S_Layer or S_MathOps, you can also combine the outputs of two effects (or stacks of effects) into a single result.

In the node graph you can move, connect, disconnect, disable and preview nodes. Right-clicking on a node brings up a context menu of useful items.

To connect a node to the graph, drag it onto any line. If it was previously connected somewhere else, this will move it. You can also drag a node onto another node, which will connect it after the other node. Shift-drag a node to disconnect it.

Parameters

The Parameters panel is where all the parameters for the currently selected node can be edited and published back to After Effects or Premiere. It only shows parameters for one node at a time; to edit params for a different node, just select it in the node graph. You can rename the current node here; just type a new name into the Node Name box. You can also load a preset for the current effect from the Parameters panel, choosing from the GenArts-provided set of thousands of presets or ones you've created yourself.

The checkboxes on the right side are used to publish params to After Effects or Premiere; published params show up as params in the final effect where users can make further changes or add animation. Non-published params don't appear in AE or Premiere at all; this can be useful to simplify the params of the effect you're creating, or prevent users from accidentally changing important parameters. They will still take on their correct values, but users who just apply your S_Effect preset won't be able to see or change them.

You can adjust params using the slider, by dragging directly on the numbers, or by clicking in the number text and typing a new value. Shift-dragging on the numbers goes faster, and Ctrl-dragging on the numbers goes slower.

The master checkbox at the top publishes or un-publishes all the params for the current node at once; this can be useful if you've got too many params defined and builder warns you you have to un-publish some. In that case you have to un-publish all the params of one or more effects.

Animation

Each parameter has an animation button that allows you to define animations. In Transition mode, most nodes will have a predefined parameter already animated in a way that makes sense for a transition, but you can change these. There are various animations you can choose from:

Ramp Up or Down (starting from zero or one)
increase or decrease the value of the parameter as the transition progresses. Use this, for instance, to blur the outgoing and incoming clips oppositely to get a blur dissolve.
Up/Down (starting from zero or one)
increase to the midpoint, and then decrease again. Use this, for instance, to add a "hit" of brightness or glow in the middle of a transition to get a flash-frame transition.

You can further adjust the shape of each curve by dragging the sliders for Slow In, Slow Out, Start Time, End Time, Mid Time, and Slow Middle.

Creating Effects

Adding Nodes

You can add nodes to the graph by double-clicking them in the Components panel or dragging them from that panel into the graph. If you double-click, the new node will go after the currently selected node, or just before the result if no node is selected.

To connect two nodes, drag the connecting output arrow from the source to the destination, or drag from the destination's input circle up to the source's output. To connect multiple nodes to the same source node, you have to use the latter method, dragging from the destination to the source.

You can neaten the layout of the graph at any point by using Edit -> Clean Up All.

Previewing nodes
To preview a node anywhere in your graph, i.e. to see what that node's output looks like, click Preview selected node at the bottom of the node graph, then select the node you want to examine. Its output will appear in the large preview window above.
Matte/secondary inputs
Many Sapphire nodes have secondary inputs; these appear as small circles on the left or right side of the node. Mousing over that circle will show the name of the input. The most common secondary input is a matte. A simple way to use these is to create a matte using S_Vignette (set to Vignette Only mode) or S_Shape. Connect the output of that node to the matte input of the desired node to use it as a matte for that node.

Starting with Sapphire 10 Builder has a Mask node which represents the clip (or path) connected to the Mask input in the host. Connecting the Mask node in Builder to an input of an effect will pass the clip from the host to the effect. The Mask (and Background) nodes are only visible in Effect Builder, not in Transition Builder.

Layering with S_Layer
Often you will want to combine two images. S_Layer and S_MathOps are good ways to do that. S_Layer composites with alpha by default, while S_MathOps adds the two inputs by default. S_Layer can also be used to combine two images using a matte: connect the matte to its side Matte input, leave it set to Normal mode, and turn off its Comp Premult parameter.

Creating Transitions

You can use Builder to create transitions as well as effects; just start with S_Transition. In this case, the node graph will start with a default dissolve transition between the outgoing and incoming clips. You can play through the transition to see how it looks.

You have tremendous flexibility when designing transitions; you can add effects to the outgoing and incoming clips, you can change the underlying transition, and you can add effects to the result.

You can also change the speed of the the underlying dissolve by selecting the Transition node and adjusting Dissolve Speed; if you increase that speed, the dissolve will happen more quickly in the middle of the overall transition.

Saving and Loading Effects

When you press OK to close the Builder interface, you will be taken back to AE or Premiere with the current effect as you've defined it. That effect will be stored with your project; to take it to a different machine you don't have to save any external files. (Pressing Cancel leaves the effect as it was before you started the builder UI.)

You can also save effect definitions as "presets", to share with other users or to define a look for a show or project. These presets are simple text files, so you can send them via email or put them on a shared drive. They are cross-platform, meaning they work on all video systems which support Sapphire and Builder, for instance Avid Media Composer. These presets can be loaded back into Builder for further editing, and they also appear in the preset browser when loading presets for S_Effect or S_Transition.

Restrictions

There are a few restrictions on what you can create with Sapphire Builder.
Popup params
Popup params (params that have a menu of choices) can't be published to your Adobe product. You have to set them as desired within the builder interface.
Too many params
If you publish too many params, we may not be able to show all of them in AE or Premiere. Builder will warn you in that case; you can simply un-publish all the params of one or more nodes. That will free up space for publishing something else. You can use the master checkbox at the top to un-publish all the params of any node.
Param groups
Some Sapphire effects collect their params into groups. In Builder, the groups are used for effects within the composite builder effect, so the lower level groups are removed.
Temporal effects
Some Sapphire effects can't be used as nodes in Builder, notably temporal effects (effects that modify time) such as S_TimeWarpRGB and S_Retime.
Widgets
Sapphire effects that would have on-screen widgets in AE or Premiere don't have them when used as Builder nodes.


Using Mocha in Sapphire

What is Mocha?

Mocha is a planar tracking and masking utility that can save time on the most difficult motion tracking and masking shots. It tracks the entire area of the mask, not just individual points, to significantly reduce the tedium of manual keyframing.

Mocha looks for 3-d planes in the image: pixels that move together. Screens and signs are clear candidates, but Mocha can also track faces. It can handle objects obscured by foreground elements, and can track unlimited layers all at once.

There's a lot more to Mocha than we can explain here; there are plenty of tutorials online at http://borisfx.com.

In Sapphire, Mocha works as a mask for the effect, similarly to the mask input, but with all the tracking features of Mocha. For instance, in S_DistortRGB, the mask affects the amount of RGB distortion. In S_Glow, the mask masks out the areas you want to emit glowing light, without chopping off the smooth edges of the glow.

How to use it

  1. Apply a Sapphire effect
  2. Most Sapphire effects now feature Mocha planar tracking integrated within the effect. Certain effects were omitted because utilizing a mask made no logical sense; for example, none of the S_Transition effects incorporate S_Mocha, and the Z_effects which require a Z_depth matte to work were also skipped.

  3. Click Edit Mocha to launch Mocha
  4. When you click the Edit Mocha button, you will launch the Mocha UI, which will allow you to create and track a mask for use back with the selected Sapphire effect in your host application.

  5. Create a spline
  6. You can create a shape to track within Mocha utilizing either an X-spline or Bezier splines. X-splines are recommended for most uses.

    Draw one or more splines around the planar areas you would like to track.

  7. Track it
  8. You can use backwards and forward tracking from whatever frame you're parked on. You can often get a great result with default settings, but if you're getting a lot of drifts, try increasing the Min K Pixels Used .

  9. Save and exit back to host
  10. For your mask to appear back in your host application, YOU MUST SAVE AND EXIT. If you exit without saving, all you current work will be lost. Always save and exit!

  11. Adjust in Sapphire
  12. You can make additional fine tuning adjustments after tracking in Mocha by opening the "Mocha" pulldown in your selected Sapphire effect. Additional softness and position/scale paramters can be found here, as well as checkboxes for soloing/hiding/inverting the Mocha mask.

  13. Moving masks between effects
  14. Sometimes you track a shot with Mocha in one Sapphire effect and would like to reuse the track in a different effect. The simplest way is to export it from the first effect and re-import into the second effect.

    1. go into Mocha with Edit Mocha , then File > Export to export the Mocha project to a file.
    2. Exit Mocha and delete the old effect.
    3. Apply the new effect, Edit Mocha , and File > Merge the project from the file you saved.

    Alternatively, if you want to share a Mocha mask with several effects, track the mask in a simple Sapphire effect such as S_HueSatBright. In there, select Show Mocha Only . Then use that as the Mask input to the effects where you want the mask used. (Exactly how to do this varies with host app.) Since the Mocha mask acts just like a regular mask input, this will allow you to update the mask once and all the other effects will use it.

Resetting Parameters to Defaults

In Adobe products, you can reset all of a plug-in's parameters to their default values by clicking on the Reset button just to the right of the plug-in name in the timeline. Individual parameters can also be reset to their default values from the Effect Controls editor by right-clicking on the parameter and then selecting Reset .


Online Documentation

In Adobe After Effects, all Sapphire Plug-ins include an About button to the right of the plug-in name. Push this button to bring up a window showing the current version of Sapphire Plug-ins and your license status. All plug-ins also include a Help button at the bottom of the effect control window. This button brings up a more detailed dialog showing some documentation about the current plug-in, and links to more detailed HTML documentation. It also shows the GPU status of the current plug-in, and allows you to enable or disable the GPU acceleration as desired.

Online documentation is normally installed along with your software and can also be accessed directly. On Windows go to Start -> All Programs -> GenArts Sapphire AE -> Online Help (HTML) or (PDF). On Mac, go to the /Applications/GenArtsSapphireAE folder and double click on Online Help.html or .pdf.


GPU Acceleration

Many effects can use the GPU to speed up rendering. This requires an NVIDIA graphics card which supports CUDA, such as a GeForce 280 or 285, or Quadro FX 5600 or 5800. If a suitable GPU is found, a GPU Enable button will appear in the Help dialog. GPU acceleration is enabled by default if it's available, but if you experience performance or stability problems, you can turn it off by deselected the GPU Enable button.

If a plug-in is unable to render on the GPU, it will automatically fall back to the CPU and continue processing. The GPU status, including the type of error, is displayed in the Help dialog.

On machines with more than one GPU that supports CUDA, you can select which GPU Sapphire Plug-ins will use by changing the value of use_gpu in the s_config.text file.


About Motion Blur

Many Sapphire Plug-ins can simulate motion blur by rendering the effect at multiple times and averaging the results together. In After Effects, these plug-ins will automatically use the composition and layer settings for motion blur.

To enable motion blur, click on the Motion Blur button in the composition window, and also enable it for the layer to which your Sapphire plug-in is applied. You can then adjust the settings from the Advanced tab of the Composition Settings window.

In Premiere and other AE-compatible hosts, motion blur is controlled by three parameters:

  • Enable Motion Blur turns motion blur on or off.
  • Shutter Angle controls the amount of time that the simulated shutter is open, and thus the overall amount of motion blur. The default value of 180 degrees will blur over an interval of half a frame, which is a common setting for real cameras. A value of 360 degrees will blur over an entire frame, which is the maximum amount of motion blur possible with a real camera. Values above 360 degrees will produce unrealistic results in which the motion of adjacent frames overlaps.
  • Samples controls the number of individual renders that are averaged together. Increasing the number of samples will give smoother results, but will also increase render times. If too few samples are used, there can be visible aliasing or ghosting artifacts. Faster motion will require more samples to avoid artifacts.

About Matte Inputs

Many Sapphire Plug-ins accept an optional Matte input clip. Typically, this input can be used to provide more detailed control for where the effect should be applied and where it should not be applied.

Glint , Glow , Glare , and Rays , for example, take the main Source input and also an optional Matte input. For these, the source input is multiplied by the matte before generating the glints (or glows, glares), so where the matte is black no glints are generated, and where it is white they are generated as usual. This method prevents the glints or glows themselves from being partially cropped by the matte. In addition these effects use the RGB colors of the Matte input to selectively colorize the resulting glows, glints, or glares. The red areas of the matte will produce red glows, glints, or glares, and so on.

In Blur effects, the areas which are matted out are never blurred, so they do not blur into the matted-in regions. If a matte were instead applied afterward, the pixels behind the matte would be blurred over the edge of the matte and into the final image. As an example, say you have a clip with white text over a black background. If you put that clip into both the Source and Matte inputs of Blur, the black background will not be blurred into the text, since the black pixels are all matted out.

For a few compositing effects, Layer , DropShadow , EdgeFlash , MatteOpsComp , and RackDfComp , the Matte input instead indicates the opacity of the foreground clip. This can be used to give the plug-in different opacity values than the usual alpha channel of the main foreground input.


About Alpha Channel Processing

All Sapphire Plug-ins can handle RGBA inputs, and the Alpha of RGBA inputs is handled in one of three ways, depending on the effect:

  1. Alpha is processed as just another input channel like R, G, and B. Effects in this category include: AutoPaint, Mosaic, Blur, BlurMotion, RackDefocus, all Wipes, all Dissolves, Distort, DistortBlur, DistortChroma, all Kaleidoscopes, all Warps, Shake, and MathOps.

  2. Alpha is copied from the first input to the output. In this case the effect doesn't use the Alpha channel, but it is passed through unchanged from the first input to the output. Effects in this category include: BandPass, BlurChroma, ClampChroma, DuoTone, EdgeDetect, Embosses, Etching, HalfTones, Hotspots, DistortRGB, Monochrome, Pseudo_Color, Psykos, Sharpen, Sketch, Sparkles, Streaks, Threshold, and Zebrafy.

  3. Some other effects pass the input Alpha channel through, and also add some opacity where the effects are applied. An Affect Alpha parameter is included in these effects which allows adjusting the amount that the alpha channel is affected. The effects in this category are: LensFlare, all Glows, all Glints, Glare, EdgeRays, Rays, and all Zaps.

Most Sapphire Plug-ins include a Opacity parameter that also affects how alpha is processed. Normal Opacity indicates that the input images are "non-premultipled" or straight format which is typical for After Effects.

If the Opacity parameter is set to All Opaque, the input alpha is ignored (it's treated as if it were fully opaque), and the output alpha is set to 1. This option is slightly faster, and is appropriate if your images should be fully opaque. After Effects 7.0 and later support the Smart FX API, which allows the plug-in to automatically detect fully opaque input clips and process them faster, so you don't need to set All Opaque to avoid processing full-white alphas.

The Opacity parameter can also be set to AsPremult to indicate the input clips are in "premultiplied" format. In this case the RGB values of input images are assumed to be already scaled by their Alpha (opacity) values, and the output images are also generated in this format. This option is less commonly useful, but may be appropriate if the transfer mode of your layer is set to Luminescent Premult.

A few plug-ins such as the Clouds and Texture generators include both an Input Opacity and an Output Opacity parameter. The Input Opacity gives the Normal, All Opaque or AsPremult options as described above, and the Output Opacity allows selecting between copying the opacity directly from the input, or setting the output to all opaque.


About Angle Parameters

Many Sapphire Plug-ins include parameters that adjust angles. These parameters are in degrees, so 180 is half a revolution and 90 is a quarter, etc. On AE, Premiere, and Combustion, a positive change in the parameter value corresponds to a clockwise rotation. In Eyeon Fusion, however, a positive change is a counter-clockwise rotation. This makes the behavior of the plug-in angles consistent with typical angles in each host application. The values, including the default values, are negative on Eyeon Fusion relative to the other host applications.

In AE and Premiere, there is an option to use dials rather than sliders for angle parameters. This allows you to turn the parameter value around in the user interface in a way that corresponds to the actual rotation.

Some users prefer these rotating dial options, while others prefer the usual parameter sliders. Variables are provided in the Sapphire Plug-ins s_config.text file that allow each user to set their own preferences. You can independently indicate if you want dials on AE and other applications that might support them. By default all host applications use sliders. See the section below on Customizing Plug-ins for information on how to edit this config file and change these options.


About Pixel Aspect Ratios

For some image formats, the digital form of the image is scaled non-uniformly to produce the final viewed picture. For example NTSC resolution is normally 720x486 with an aspect ratio of 1.481. However, the final NTSC picture has an aspect ratio of 1.333. Thus the original digital image is scaled in the horizontal direction by a factor of 0.9 and shapes rendered as circles can end up squashed slightly into ovals. The original pixels are effectively rectangular shaped instead of squares, and have an aspect ratio of 1.481/1.333 = 1.111. (Or 1.333/1.481 = 0.9 if the inverse ratio is used.)

After Effects allows you to adjust the pixel aspect ratio in the Composition Settings menu, and Sapphire Plug-ins read this value to give the appropriately scaled results.

If necessary, you can override the pixel aspect ratio for all Sapphire Plug-ins by changing the value of force_pixel_aspect_ratio in the s_config.text file.

The pixel aspect ratio makes no difference for basic pixel processing effects such as color processing or compositing.


Customizing Plug-ins

A number of parameters are available that can be adjusted to customize the behavior of all Sapphire Plug-ins. You can disable multi-processing, choose to use dials for angle parameters, force the pixel aspect ratio, or specify lookup tables for more accurate processing of log format images. A facility is also included with Sapphire Plug-ins that allows users with some programming experience to define and customize new plug-ins. For additional information on these, or to modify a parameter, see the s_config.text file.

On Mac the config file is located at /Applications/GenArtsSapphireAE/config/s_config.text

On Windows the config file is located at C:\Program Files\GenArts\SapphireAE\s_config.text .

Custom Lens Flare types can also be made by editing the s_lensflares.text file, in the same directory as the config file above. New flare types will automatically appear in the menu of the S_LensFlare plug-in.


Known Problems

  1. In Premiere, Mocha mask generation doesn't work on adjustment layers, shape layers, or text layers due to time issues in the host.
  • Workaround: create the mask with an effect on a regular clip, then export and re-import into the effect on the adjustment layer.

  • Any S_Effect saved with an earlier version containing WarpDrops will render incorrectly after installing Sapphire 11. The effect can be fixed by clicking "Edit Effect" to open Builder, and then clicking "OK" to update the effect to Sapphire 11.
  • Premiere Pro versions prior to CC 2015 have limited support for the Effect Builder.

  • The Feedback and Trails effects sometimes do not render correctly unless the cache is cleared first. These effects must also render frames in sequential order.

  • On After Effects, adjusting parameter values by directly dragging on the number with small ranges is sometimes too sensitive. This is because AE sets the sensitivity automatically using the valid range of the parameter, and does not always adapt to small slider ranges correctly. A workaround is to hold down the Control or Command key while dragging.

  • After Effects expressions may break when loading projects that were saved with older versions of Sapphire. Any Sapphire Plug-ins in use where the parameters changed between versions may have broken expressions when older projects are loaded. To work around this problem, delete all expressions in the affected Plug-ins and recreate those expressions. To see a list of Plug-ins with new parameters, see the what's new notes. . This will only break between major versions of Sapphire.

  • Importing Premiere Pro projects into After Effects using File->Import->Adobe Premiere Pro Project... may not import projects containing Sapphire correctly.
    • Layer parameters (e.g. Mattes) are not set properly.
    • Lensflares and glares are reset to their default values
    • S_Effect and S_Transition are reset to their default states (no effect loaded).

    We hope these problems will be fixed in a future release of After Effects. In the meantime, we recommend importing Premiere Pro projects as clips using File->Import File... instead.

  • When loading presets in Premiere Pro, point parameters may be set incorrectly if the effect is on a clip that's smaller than the sequence. We hope this problem will be fixed in a future release of Premiere Pro. In the meantime, loading the preset a second time will sometimes produce the correct result.
  • Starting with Sapphire 8.13, the Set Hold Level button in FlickerRemove does not work on text layers in After Effects CC 2015.

  • To Sapphire Plug-ins Introduction


    PRODUCT UPDATES & SPECIAL OFFERS

    Join our email newsletter and keep up to date