Sapphire Plug-ins v11.01 for Avid Products

Sapphire Plug-ins v11.01 for Avid, General User Info



What's New In This Version

New Effects:

  • S_VignetteMocha creates a vignette using a Mocha-tracked mask as the shape of the vignette. All the options of regular Vignette are available.

New Features:

  • Mocha tracking and masking is added to most effects
    • Exceptions: Transitions, Z effects, Retime, RackDfComp, RepairFrames
  • Many more effects have mask inputs now (over 80 more). Almost all the ones that didn't before, where it makes sense. Some examples: Aurora, Cartoon, Clouds, DigitalDamage, and Layer.
  • S_Grunge now has a Crop Grunge to Mask parameter.
  • Glint, GlintRainbow and Glare can now select luma, color or alpha for the mask using new Mask Type parameter.
  • S_Swish3D's default wrap behavior has been changed to Repeat.
  • Loading a single-effect preset into Builder or S_Effect will now automatically connect the Mask node to the Mask input of the effect node.

Fixes:

  • Streaks, Rays and EdgeRays are now more stable when downsampling via Streaks/Rays Res and cropping. Projects with these may look slightly different.

New in 11.01:

  1. Fixed a bug that changed the rendered output of all Glows (e.g. S_Glow, S_GlowEdges, etc.) and Sparkles (both S_Sparkles and S_SparklesColor) between v10 and v11.0 if the user provided a color mask. These effects are now compatible with v10's output but the output will change relative to v11.0! To get the output from v11.0 back, apply S_Monochrome to the mask before passing it to the effect.
    • Note: This also affects any S_Effect presets made with v11.0 using Glows or Sparkles. Please check your presets for Glows or Sparkles and update with S_Monochrome if needed for the desired behavior.
  2. VignetteMocha mode of S_Vignette now starts with an empty Mocha project. In this case VignetteMocha will use a circular mask until a Mocha Mask is set. This circular mask will not show up in the Mocha UI.
    • Note: If you used the default Mocha project in VignetteMocha (M in a hexagon) in Sapphire 11.0, your rendered output will change in 11.01.
  3. Mocha help link now points to Sapphire Mocha help instead of BCC Mocha help.
  4. Mocha now remembers the previous Open Project and Export Project locations.
  5. Mocha in Sapphire and Mocha in BCC now save preferences and settings separately.
  6. Updated list of known issues (below).
  7. Minor preset improvements.

Loading a Plug-in

The plug-ins appear in the Effect Palette under the Sapphire categories.

You can drag a plug-in onto a track just as you would any other effect. After you apply a plug-in to a track, select Effect Mode to display the Effect Editor which allows you to adjust the controls and parameters for that effect.

On DS, the Sapphire presets have moved to an easier location. You should now find the Sapphire effect presets in the DS Presets/Image Effects/Sapphire folders. You can apply Sapphire effects directly on clips, as transitions, or in a tree, and you can load a Sapphire effect either from a preset or using the AVX2 Host preset in Image Effects .


Browsing and Selecting Presets

You can load and save presets for effects using the Load Preset and Save Preset buttons near the top of the effect palette window in all Sapphire effects.

Loading:

In the preset browser you'll see all the presets available for the current plug-in, both GenArts-supplied presets and the ones you've created yourself. You can filter by tags on the left side to quickly find the look you're interested in.

The main top window shows the preset on your footage (unless the plug-in can't access the AE layer for some reason, in which case you'll see a poster frame) and various information about the preset.

At the bottom you see all the presets; you can enlarge or shrink them with the slider at the bottom. You can also switch to a table view there, as well as viewing the preset on your source, over black, or over the sample footage. You can also see the source all by itself for comparison.

Saving:

Clicking Save Preset brings up the Save Preset dialog. Here you can name the preset, and add various other information. Particularly important is the tagging system; you can apply as many tags as you want to your presets. You can even create new tags. Tags are grouped into categories, so all the color names appear under Colors, for instance.

You can create new categories as well, by typing into the Category drop-down menu after clicking Add New Tag.... GenArts recommends sticking to the shipped categories when possible, for compatibility. But adding your own tags within categories (new color names, for example) is encouraged.

More Info:

While the preset browser, save dialog, or flare designer are open, the main AE window will be unresponsive. This is normal. Close the preset browser or flare designer and AE will wake up again.

Certain parameters, like Lens Flare hotspot, are not saved in presets; we thought it would be less than useful for the flares to jump around as you load presets.

It may take a few seconds to load the preset browser if a plug-in has many presets. Be patient.


Using the Sapphire Effect Builder

Builder lets you design completely new effects by combining several Sapphire effects together. The result is a new effect that does what all the different effects you add to the workspace do, but it can be applied and used as a single effect.

Starting Builder

To use the Effect Builder, apply S_Effect or S_Transition (both in the Sapphire Builder category) to a clip, or between two clips in the case of S_Transition. Then press the Edit Effect button to bring up the Builder interface. Create the effect in the builder interface, then when you return to Avid your new effect will be there, with all of its published parameters. You can also load effects you've defined before, using the Load Preset button in these effects. The builder interface is composed of several panels, described below.

Panels

The builder interface is where you create and customize your new effect. All the panels are movable and resizable so you can customize the layout for your particular work style.
Components
The Components panel lists all the Sapphire effects. They're listed by category, and you can search for any one you want; you can also organize them alphabetically. To add an effect to your workspace, double-click it or drag it onto a line on the node graph, or onto another node to add it after that one.

The Tools category contains tools that are only available in Builder:

Color
creates a solid color
Composite
a simple premultiplied composite. Use when the foreground clip already has an alpha channel.
Blend
dissolve between two clips using a Matte input. Use when the foreground clip does not have an alpha channel.
Crop
crop to a rectangular area
Cutout
crop input to an arbitrary shape, given by a Matte input. The Matte multiplies with any alpha channel that's already present.
SetAlpha
add an alpha channel to a clip which doesn't have one, and premultiply.
Sticky Note
write notes in the workspace
Preview Window
The preview window is where you see the result of the effect you're creating. It has a play bar so you can see any animation in the nodes you've added. You can also play through transitions if you're using S_Transition.
Node Graph

The Node Graph is where you build the new effect. Processing flows from the Source node to the Result node; you add whatever effects you want in between to build a processing pipeline. Using multi-input effects like S_Layer or S_MathOps, you can also combine the outputs of two effects (or stacks of effects) into a single result.

In the node graph you can move, connect, disconnect, disable and preview nodes. Right-clicking on a node brings up a context menu of useful items.

To connect a node to the graph, drag it onto any line. If it was previously connected somewhere else, this will move it. You can also drag a node onto another node, which will connect it after the other node. Shift-drag a node to disconnect it.

Parameters

The Parameters panel is where all the parameters for the currently selected node can be edited and published back to Avid. It only shows parameters for one node at a time; to edit params for a different node, just select it in the node graph. You can rename the current node here; just type a new name into the Node Name box. You can also load a preset for the current effect from the Parameters panel, choosing from the GenArts-provided set of thousands of presets or ones you've created yourself.

The checkboxes on the right side are used to publish params to Avid; published params show up as params in the final effect where users can make further changes or add animation. Non-published params don't appear in Avid at all; this can be useful to simplify the params of the effect you're creating, or prevent users from accidentally changing important parameters. They will still take on their correct values, but users who just apply your S_Effect preset won't be able to see or change them.

You can adjust params using the slider, by dragging directly on the numbers, or by clicking in the number text and typing a new value. Shift-dragging on the numbers goes faster, and Ctrl-dragging on the numbers goes slower.

The master checkbox at the top publishes or un-publishes all the params for the current node at once; this can be useful if you've got too many params defined and builder warns you you have to un-publish some. In that case you have to un-publish all the params of one or more effects.

Animation

Each parameter has an animation button that allows you to define animations. In Transition mode, most nodes will have a predefined parameter already animated in a way that makes sense for a transition, but you can change these. There are various animations you can choose from:

Ramp Up or Down (starting from zero or one)
increase or decrease the value of the parameter as the transition progresses. Use this, for instance, to blur the outgoing and incoming clips oppositely to get a blur dissolve.
Up/Down (starting from zero or one)
increase to the midpoint, and then decrease again. Use this, for instance, to add a "hit" of brightness or glow in the middle of a transition to get a flash-frame transition.

You can further adjust the shape of each curve by dragging the sliders for Slow In, Slow Out, Start Time, End Time, Mid Time, and Slow Middle.

Creating Effects

Adding Nodes

You can add nodes to the graph by double-clicking them in the Components panel or dragging them from that panel into the graph. If you double-click, the new node will go after the currently selected node, or just before the result if no node is selected.

To connect two nodes, drag the connecting output arrow from the source to the destination, or drag from the destination's input circle up to the source's output. To connect multiple nodes to the same source node, you have to use the latter method, dragging from the destination to the source.

You can neaten the layout of the graph at any point by using Edit -> Clean Up All.

Previewing nodes
To preview a node anywhere in your graph, i.e. to see what that node's output looks like, click Preview selected node at the bottom of the node graph, then select the node you want to examine. Its output will appear in the large preview window above.
Mask/secondary inputs
Many Sapphire nodes have secondary inputs; these appear as small circles on the left or right side of the node. Mousing over that circle will show the name of the input. The most common secondary input is a mask. A simple way to use these is to create a mask using S_Vignette (set to Vignette Only mode) or S_Shape. Connect the output of that node to the mask input of the desired node to use it as a mask for that node.

Starting with Sapphire 10 Builder has a Mask node which represents the clip (or path) connected to the Mask input in the host. Connecting the Mask node in Builder to an input of an effect will pass the clip from the host to the effect. The Mask (and Background) nodes are only visible in Effect Builder, not in Transition Builder.

Layering with S_Layer
Often you will want to combine two images. S_Layer and S_MathOps are good ways to do that. S_Layer composites with alpha by default, while S_MathOps adds the two inputs by default. S_Layer can also be used to combine two images using a mask: connect the mask to its side Mask input, leave it set to Normal mode, and turn off its Comp Premult parameter.

Creating Transitions

You can use Builder to create transitions as well as effects; just start with S_Transition. In this case, the node graph will start with a default dissolve transition between the outgoing and incoming clips. You can play through the transition to see how it looks.

You have tremendous flexibility when designing transitions; you can add effects to the outgoing and incoming clips, you can change the underlying transition, and you can add effects to the result.

You can also change the speed of the the underlying dissolve by selecting the Transition node and adjusting Dissolve Speed; if you increase that speed, the dissolve will happen more quickly in the middle of the overall transition.

Saving and Loading Effects

When you press OK to close the Builder interface, you will be taken back to Avid with the current effect as you've defined it. That effect will be stored with your project; to take it to a different machine you don't have to save any external files. (Pressing Cancel leaves the effect as it was before you started the builder UI.)

You can also save effect definitions as "presets", to share with other users or to define a look for a show or project. These presets are simple text files, so you can send them via email or put them on a shared drive. They are cross-platform, meaning they work on all video systems which support Sapphire and Builder, for instance After Effects or Premiere. These presets can be loaded back into Builder for further editing, and they also appear in the preset browser when loading presets for S_Effect or S_Transition.

Restrictions

There are a few restrictions on what you can create with Sapphire Builder.
Popup params
Popup params (params that have a menu of choices) can't be published to your Adobe product. You have to set them as desired within the builder interface.
Too many params
If you publish too many params, we may not be able to show all of them in Avid. Builder will warn you in that case; you can simply un-publish all the params of one or more nodes. That will free up space for publishing something else. You can use the master checkbox at the top to un-publish all the params of any node.
Param groups
Some Sapphire effects collect their params into groups. In Builder, the groups are used for effects within the composite builder effect, so the lower level groups are removed.
Temporal effects
Some Sapphire effects can't be used as nodes in Builder, notably temporal effects (effects that modify time) such as S_TimeWarpRGB and S_Retime.
Widgets
Sapphire effects that would have on-screen widgets in Avid don't have them when used as Builder nodes.


Using Mocha in Sapphire

What is Mocha?

Mocha is a planar tracking and masking utility that can save time on the most difficult motion tracking and masking shots. It tracks the entire area of the mask, not just individual points, to significantly reduce the tedium of manual keyframing.

Mocha looks for 3-d planes in the image: pixels that move together. Screens and signs are clear candidates, but Mocha can also track faces. It can handle objects obscured by foreground elements, and can track unlimited layers all at once.

There's a lot more to Mocha than we can explain here; there are plenty of tutorials online at https://borisfx.com.

In Sapphire, Mocha works as a mask for the effect, similarly to the mask input, but with all the tracking features of Mocha. For instance, in S_DistortRGB, the mask affects the amount of RGB distortion. In S_Glow, the mask masks out the areas you want to emit glowing light, without chopping off the smooth edges of the glow.

How to use it

  1. Apply a Sapphire effect
  2. Most Sapphire effects now feature Mocha planar tracking integrated within the effect. Certain effects were omitted because utilizing a mask made no logical sense; for example, none of the S_Transition effects incorporate S_Mocha, and the Z_effects which require a Z_depth matte to work were also skipped.

  3. Click Edit Mocha to launch Mocha
  4. When you click the Edit Mocha button, you will launch the Mocha UI, which will allow you to create and track a mask for use back with the selected Sapphire effect in your host application.

  5. Create a spline
  6. You can create a shape to track within Mocha utilizing either an X-spline or Bezier splines. X-splines are recommended for most uses.

    Draw one or more splines around the planar areas you would like to track.

  7. Track it
  8. You can use backwards and forward tracking from whatever frame you're parked on. You can often get a great result with default settings, but if you're getting a lot of drifts, try increasing the Min K Pixels Used .

  9. Save and exit back to host
  10. For your mask to appear back in your host application, YOU MUST SAVE AND EXIT. If you exit without saving, all you current work will be lost. Always save and exit!

  11. Adjust in Sapphire
  12. You can make additional fine tuning adjustments after tracking in Mocha by opening the "Mocha" pulldown in your selected Sapphire effect. Additional softness and position/scale paramters can be found here, as well as checkboxes for soloing/hiding/inverting the Mocha mask.

  13. Moving masks between effects
  14. Sometimes you track a shot with Mocha in one Sapphire effect and would like to reuse the track in a different effect. The simplest way is to export it from the first effect and re-import into the second effect.

    1. go into Mocha with Edit Mocha , then File > Export to export the Mocha project to a file.
    2. Exit Mocha and delete the old effect.
    3. Apply the new effect, Edit Mocha , and File > Merge the project from the file you saved.

Editing and Designing Lens Flares and other elements

Clicking Edit Lens in LensFlare, or Edit Style in Glare or Flashbulbs, opens up the Lens Flare Designer.

The Flare Designer lets you completely customize a lens flare. You can add or remove elements, copy them, customize how each element looks, and even how it reacts to the center or edge of the image. You can also interactively move the flare around to see how it will look as it moves.

All the panels of the Flare Designer are movable, so you can adjust the user interface itself to suit your work flow. The main panels are the view window, where you see the flare you're working on, the Elements panel which lists all the elements of the flare, and the Properties panel, which lets you adjust the properties of the currently selected element (or elements). There's also a toolbar of element templates at the top.

View Panel

The main view window is where you see how your flare will look; you can click and drag to move the flare around. You can see it over the background or just over black, adjust the gamma, and Solo only the selected elements. Use Plug-in Settings makes the flare designer import the plug-in settings currently active in the host app. If you have that selected, the flare will look the same back in the host app when you're done designing it. On the other hand, if you want to create a "reusable" flare preset, it's probably a good idea to un-check Use Plug-in Settings so the flare will look good with default settings in the plug-in.

Elements Panel

The Elements panel shows you all the elements, with thumbnails. If you mouse over them, an overlay shows where they are in the main view window. When you click on an element to select it, it also flashes brighter in the main window to help you find the element you're looking for. Clicking Identify in the Properties panel does the same flashing.

To add new elements, just click the element template picture in the top toolbar. You can then rename the element, move it in the list by dragging and dropping, or hide it by un-checking the checkbox.

To delete an elements, select it and click the trash can icon at the bottom of the Elements panel, or click Delete. There is full undo, so feel free to experiment!

You can also duplicate an element using standard copy/paste operations, or select it and click the two pages icon at the bottom of the Elements panel. You can then adjust the copy's parameters in the Parameters panel.

The gear-looking element is the "advanced element" type; it has lots of controls and is very customizable, but it's recommended for advanced users only. The other types get you most of the same looks with simpler parameters.

Along with all the standard element types, you can import your own images to use as elements. Click the picture frame to import an image file. The image data will become part of the flare, so it doesn't need to keep a reference to the original file.

To combine two flares into one, or add many elements at once, you can import another flare into your current flare; this will add all the other flare's elements to your current flare. You can also just open that flare, which replaces your current flare with that one. To import and add to your flare, use Insert Flare (down-right pointing arrow in the toolbar), or File... Insert Flare. To import and replace, use Open Flare (folder icon in the toolbar), or use File... Open Flare.

Parameters Panel

The Parameters panel is where you adjust all the details of a single element -- or multiple elements together, if you select multiple elements in the Elements panel. (Use Shift-click or Control-click to select multiple elements.)

There are a few common control types. Sliders with numbers to the left control numeric params; you can drag the slider thumb, but you can also drag in the number text field to increase or decrease the value. You can also click in the number field and type any value you want.

Color controls are just a swatch of color; click to bring up a standard color picker.

Some elements have a Gradient; there's a special gradient control to adjust those. The stops are below the color swatch; you can drag them left and right to move them. Drag down to delete. Click in the color gradient to add a stop there. Control-drag to "stretch" neighboring colors, and shift-drag to push neighboring colors. The triangles above the color gradient allow you to control the interpolation of the colors between stops. Ring Thickness lets you easily turn a spot or fan of rays into a ring; turning Ring Thickness down from 1 hollows out the center. This lets you still have fine control of the colors within the ring, even if it's very thin.

Different element types will have various parameters you can adjust, but here are some common ones:

Position
Where the element occurs, along the line between the hotspot and pivot point. Position 1.0 is at the hotspot, 0.0 is at the pivot. Note that you don't have to stay in that range; you can use any value you like. Bigger than 1 will be past the hotspot, and less than zero will look like a reflection because it's on the other side of the pivot point.
Size
How big the image is.
Rel Width, Rel Height
Use these to squash and stretch.
Rotate
Rotates the element around, in degrees.
There's a Reset button at the bottom of the Parameters panel to reset the current element(s) to all default settings. That's undoable too.

More Information

If you open the flare designer from the plug-in, you can just click OK to close the window when you're done; your current flare will be used in your project and saved with it. But you can do more than that; you can save the flare definition to disk separately, so you can recall it later, or use it in other flares. You can also open the flare designer directly from the Start menu or Applications folder to create flares independent of your host product. In this case, use File...Save Lens As... to save the flare definition. That dialog will allow you to name the lens and tag it so it's easy to find later.

Note that saving a lens this way does not save your plug-in settings; it only saves the lens flare definition itself (the things you can change in the flare designer). You can save a preset in the host application to save everything -- the flare and all the regular plug-in parameters.

While the preset browser, save dialog, or flare designer are open, the main AE window will be unresponsive. This is normal. Close the preset browser or flare designer and AE will wake up again.


Online Documentation

All Sapphire Plug-ins include a Help button just below the effect name in the Effect Editor window. Push this button to bring up a window showing the current version of Sapphire Plug-ins, your license status, some documentation about the current plug-in, and links to more detailed HTML documentation.

Online documentation in HTML or PDF format can also be accessed directly. On Windows go to Start -> Programs -> GenArts Sapphire AVX -> Online Help (HTML) or (PDF). On Mac, go to the Applications/GenArtsSapphireAVX folder and double click on Online Help.html or .pdf.


Processing Titles and Keys

Sapphire v11.01 allows you to easily process a title or key without affecting the background. To do this, drop a Sapphire Plug-in onto a title or key and then select the Apply To Title/Key checkbox in the Effect Editor. This causes the plug-in to process the fill and matte of the title together. By default it will also combine this result with a background that is one track below, but the Background input selector allows choosing "This Track" or "None" for the background instead.

When you replace a title effect in this way, any animation curves in the title are lost, and only the matte and fill clips remain. If you want the title to move, you can instead use the Crop/Transform parameters described below to perform the moves within the Sapphire effect.

You can also apply more than one Sapphire Plug-in to a title or key without affecting the background. To do this, drop the first effect onto the title and select Apply To Title/Key as above. But then change its Background input to "None" to prevent it from compositing. Next, apply another Sapphire effect by alt-dropping it on the first effect, but leave Apply To Title/Key unselected this time. You can alt-drop any number of additional effects in this way. In the final effect, set the Background to "1 Track Below" to composite the final result. Note that only the first effect should have Apply To Title/Key selected, and only the last effect should have a Background selected. You should use only Sapphire effects between this first effect and the final composite, because other effects will probably not pass the alpha channel through in a compatible way.

If you have your own separate matte and fill tracks you can also combine and process these together in a similar way. First make sure your matte is on a track above the fill, for example matte on v3, fill on v2, and background on v1. Drop an effect on the matte track (v3) and select Apply To Title/Key in that effect. The Background track selection defaults to "1 Track Below" which now is v1 because "This Track" becomes v2 and v3 combined. As above, you can apply multiple effects by setting the Background to "None" on the first effect, alt-dropping additional effects, and setting the last effect's Background to "1 Track Below".

In general, to view the alpha channel of a clip, you can use ChannelSwitcher and set some or all of the RGB channels to Alpha.

The above methods are not necessary if you want to process a title and its background together with the same effect. In this case you can just alt-drop the effect on the title (instead of drop) and leave Apply To Title/Key unselected. When Apply To Title/Key is not selected, the input track menus will include an additional option for "2 Tracks Below" because one of the plug-in input tracks is not used up by the matte channel.

The Wipe and Dissolve transition effects do not include an Apply To Title/Key option, because they are required by AVX to accept only 2 inputs, and therefore can not replace a Title which requires 3 inputs.

If you are using Xpress DV and processing a title with multiple nested plug-ins, make sure you turn OFF real time mode. Real time mode will corrupt the alpha channel being passed from one plug-in to the next.


Crop and Transform Parameters

Sapphire Plug-ins include a Crop/Transform Input parameter category, that includes parameters for cropping, scaling, and shifting the input clips before they are processed by the effect. The Source clip and other optional inputs are cropped and transformed, but Background inputs are not affected.

Crop Top, Crop Bottom, Crop Left, Crop Right are used to select a rectangular subsection of the image to be processed. A "Show Crop Widget" mode button on the far right column of the Effect Editor brings up an onscreen control for setting this rectangle visually, and a "Hide Widgets" button at the top/right removes it from view.

A Crop Output option is provided for some effects. When this is selected, the cropped area is processed as if it was the entire frame. This can be used to avoid soft edges around the crop area that may be created by effects such as Blur.

Scale adjusts the overall size of the input images. You can use this to scale while preserving the aspect ratio of the image, or you can use Scale Rel X and Scale Rel Y to scale horizontally or vertically by different factors. Shift X and Shift Y translate the input images horizontally or vertically. The values of the shift parameters are in units where 100 equals one complete screen width. A "Show Transform Widget" mode button in the far right column of the Effect Editor brings up an onscreen control rectangle for setting the scale and shift visually, and the "Hide Widgets" button at the top/right removes it from view.

When an image is cropped or transformed to expose areas beyond its edges, the border areas are made transparent, and if you select a Background input, it will show through in these areas. In this way a "picture in picture" effect can be created using any Sapphire Plug-in that has Crop/Transform parameters.

When Warp or Distort effects' Wrap parameters are set to "Tile" or "Reflect" the cropped source image will be wrapped on these new cropped or transformed boundaries. In this case, the result will still fill the frame, and the borders will not be transparent as usual. This makes it easier to avoid artifacts when distorting a clip with bad edges, but if you prefer transparent borders, set the Wrap parameters to "No" instead.

The Crop and Transform parameters are not available for temporal effects which might require access to other frames of the input, such as GetFrame, TimeSlice, FieldRemove, and FilmEffect.


Resolution, Clamp Output To Legal, and Bypass Effect

Sapphire Plug-ins also include these additional controls, located at the bottom of the parameters in the Effect Editor:

Resolution is a popup menu that allows the render resolution to be reduced to Half, Third, Quarter, and so on, for faster testing. Return this to Full resolution for the best quality results. This parameter is not provided on DS which has its own resolution controls.

Clamp Output to Legal causes the output colors to be clamped between broadcast-legal black and white. If off, the plug-in may pass through or generate non-broadcast-legal super black or super white. On DS, this parameter only affects image formats that support super-blacks and whites, such as 16bit and float.

Bypass Effect ignores the effect and the primary input clip or title is output unmodified when checked. This can be useful for quickly comparing your effect to the original image.


Resetting Parameters To Defaults

Every plug-in has two buttons that allow restoring its state to defaults. These buttons are located at the bottom of the effect's parameter page, and they act in slightly different ways.

Reset Parameter Values sets the effect's parameter values to their default values. However this does not reset keyframes, input track selections, or the state of the Apply To Title/Key checkbox.

Reset All restores all of the effect's state to its default including clearing any keyframes, as if the effect has just been re-applied to the track from scratch. If you hit either of these by accident, an Undo (Ctl-Z or Apple-Z) should reverse its effect and bring you back to the previous state.


GPU Acceleration

Many effects can use the GPU to speed up rendering. This requires an NVIDIA graphics card which supports CUDA, such as a GeForce 280 or 285, or Quadro FX 5600 or 5800. If a suitable GPU is found, a GPU Enable button will appear in the Help dialog. GPU acceleration is enabled by default if it's available, but if you experience performance or stability problems, you can turn it off by deselected the GPU Enable button.

If a plug-in is unable to render on the GPU, it will automatically fall back to the CPU and continue processing. The GPU status, including the type of error, is displayed in the Help dialog.

On machines with more than one GPU that supports CUDA, you can select which GPU Sapphire Plug-ins will use by changing the value of use_gpu in the s_config.text file.


Keyframes

Sapphire v11.01 for AVX 2 uses Avid's Advanced Keyframe Model. This allows users to have independent keyframes for single parameters, groups of parameters, or the entire effect, and to slip and edit keyframes visually. It gives a new level of flexibility to doing effects work in the Avid, but it requires some thought to use well.

If you prefer, you can use it just like the old keyframe model by selecting "Add to All Parameters". This setting is saved, and becomes the default when pressing the pink "Add Keyframe" triangle button in the viewer or effect editor. You can then add keyframes at the start and end of the clip and work as you used to.

The Advanced Keyframe Model also allows you to add individual keyframes: right-click (or Option-click on Mac) in the keyframe area of the effect editor and you can add keyframes for only the active parameter or group, or all open groups.

You can shift keyframes in time by holding down the Shift key while dragging them.

One important note is that if you're not parked on a keyframe and no keyframes are selected for a parameter, changes to the parameter value have no effect. Conversely if several keyframes are selected, changing the parameter value changes all the keyframe values.

For more information, see the section on Advanced Keyframes in your Avid documentation.


About Motion Blur

Many Sapphire Plug-ins can simulate motion blur by rendering the effect at multiple times and averaging the results together. Motion blur is controlled by three parameters:

  • Enable Motion Blur turns motion blur on or off.
  • Shutter Angle controls the amount of time that the simulated shutter is open, and thus the overall amount of motion blur. The default value of 180 degrees will blur over an interval of half a frame, which is a common setting for real cameras. A value of 360 degrees will blur over an entire frame, which is the maximum amount of motion blur possible with a real camera.
  • Samples controls the number of individual renders that are averaged together. Increasing the number of samples will give smoother results, but will also increase render times. If too few samples are used, there can be visible aliasing or ghosting artifacts. Faster motion will require more samples to avoid artifacts.

Mask Inputs

Many Sapphire Plug-ins accept an optional Mask input clip. Typically, this input can be used to provide more detailed control for where the effect should be applied and where it should not be applied. The Mask input defaults to "None" and it can be enabled by setting it to "This Track", "1 Track Below", or "2 Tracks Below" depending on which track you would like to use for the Mask. (If Apply To Title/Key is enabled, "2 Tracks Below" is removed from the menu of optional inputs because the title's matte clip uses up one of the tracks.)

Glint , Glow , Glare , and Rays , for example, take the main Source input and also optional Background and Mask inputs. If a Mask is selected, the source input is multiplied by the mask before generating the glints (or glows, glares), so where the mask is black no glints are generated, and where it is white they are generated as usual. This method prevents the glints or glows themselves from being partially cropped by the mask. In addition these effects use the RGB colors of the Mask input to selectively colorize the resulting glows, glints, or glares. The red areas of the mask will produce red glows, glints, or glares, and so on.

In Blur effects, the areas which are masked out are never blurred, so they do not blur into the masked-in regions. If a mask were instead applied afterward, the pixels behind the mask would be blurred over the edge of the mask and into the final image. As an example, say you have a clip with white text over a black background. If you put that clip into both the Source and Mask inputs of Blur, the black background will not be blurred into the text, since the black pixels are all masked out.

For the Warp effects, the Mask input can control the amplitude of warping for different areas of the image. In masked out areas (black), no warping occurs. In fully white areas of the mask, full warping occurs. But in gray areas, the amount of warping is scaled by the brightness of the Mask. The Blur Mask parameter can be useful here to soften the Mask image before it is applied and avoid artifacts that can sometimes be caused by hard edges in the Mask.

Sapphire Plug-ins that accept Mask inputs also include an Invert Mask parameter. This can be useful because the black/white of Alpha images are often backwards from what Sapphire expects. Normally Sapphire processes where the mask is white and shows the background where it is black. The Invert Mask parameter defaults ON for AVX products (except DS) when monochrome Masks are expected. However for Glows, Glints, Glares, EdgeRays, and Streaks, Masks can include color information so the Invert Mask defaults OFF for those.

DS also provides optional masking for all plug-ins which can be enabled on the Masking page. The processed result appears where the Mask is white, and the unprocessed first input (usually the background) shows through where the Mask is black. Sapphire Plug-ins with a Mask input perform their own method of Mask processing.


Alpha Channel Processing

Sapphire Plug-ins sometimes produce transparency information in an Alpha (or opacity) channel along with the RGB colors, for example when a plug-in is applied to a title or key, or when its inputs are cropped or transformed. RGBA images output by one effect can also be passed to the inputs of other Sapphire Plug-ins. When processing RGBA images, the Alpha channel is handled in one of three ways, depending on the effect:

  1. Alpha is processed as just another input channel like R, G, and B. Effects in this category include: AutoPaint, Mosaic, Blur, BlurMotion, RackDefocus, all Wipes, all Dissolves, Lens, LensBlur, LensChroma, all Kaleidoscopes, all Warps, Shake, and MathOps.

  2. Alpha is copied from the first input to the output. In this case the effect doesn't use the Alpha channel, but it is passed through unchanged from the first input to the output. Effects in this category include: BandPass, BlurChroma, ClampChroma, DuoTone, EdgeDetect, Embosses, Etching, HalfTones, Hotspots, LensRGB, Monochrome, Pseudo_Color, Psykos, Sharpen, Sketch, Sparkles, Streaks, Threshold, and Zebrafy. This is the same as what DS does if Process Alpha is disabled.

  3. Some other effects pass the Alpha through by default, but include an Affect Alpha parameter for optionally adding to the alpha channel. These are LensFlare, Glows, Glints, Glare, Rays, and Zaps.

If our method of Alpha processing is not appropriate for your application, you can usually manipulate Alpha to be what you need using the Channel Switcher.

In some cases, it is not obvious how Alpha should be processed. When possible we've chosen the method that seems best for use with 'premultiplied' compositing. This is often also called 'additive' compositing and is done when the R, G and B values have already been multiplied by Alpha:

Result = Background * (1 - Alpha) + Foreground
For example, by default LensFlare, Glows, Glints, and Glares pass the background's Alpha through to the output without modification. This is because these effects simulate light emission. They are purely additive and have no opacity themselves. You should get the correct effect if you composite the output of LensFlare (applied to an RGBA clip) over another clip using a premultiplied composite. The original clip will composite over the background using its Alpha, and the flare will simply add to the result.

Effects with an Affect Alpha parameter can optionally increase the output Alpha where the flares (or glows, glints, or glares) occur, but in this case the flare elements will become opaque and will darken the background image behind them when composited later.

On DS, plug-ins can process the alpha channel by enabling Process Alpha in the Masking tab of the parameter dialog.


Pixel Aspect Ratios

For some image formats, the digital form of the image is scaled non-uniformly to produce the final viewed picture. For example NTSC resolution is normally 720x486 with an aspect ratio of 1.481. However, the final NTSC picture has an aspect ratio of 1.333. Thus the original digital image is scaled in the horizontal direction by a factor of 0.9 and shapes rendered as circles can end up squashed slightly into ovals. The original pixels are effectively rectangular shaped instead of squares, and have an aspect ratio of 1.48/1.333 = 1.111. In addition, since AVX products except DS provide only half-height "field" images to plug-ins, the pixel aspect ratio is scaled by another factor of 2 there (2.222 for NTSC).

To compensate for this, all Sapphire Plug-ins pre-stretch or shrink their effect in the vertical direction by the inverse of this pixel aspect ratio . We use the pixel aspect ratio from your current sequence, but you can override these defaults for all effects by changing the value of force_pixel_aspect_ratio in the "s_config.text" file.

Most plug-ins also have a parameter for adjusting the relative width or height of the effect, which can be used to stretch the effect as needed on a case by case basis.

The pixel aspect ratio makes no difference for basic pixel processing effects such as Layer and color processing.


Customizing Plug-ins

A facility is included with Sapphire Plug-ins that allows users with some programming experience to define and customize new plug-ins. A number of parameters are also available that can be adjusted to customize the behavior of all Sapphire plug-ins. You can force progressive mode, disable multi-processing, or specify lookup tables for more accurate processing of log format images. For additional information on these, or to modify a parameter, open the config file which is normally located on Windows in C:\Program Files\GenArts\SapphireAVX\s_config.text . On Mac OSX it is in Applications/GenArtsSapphireAVX/config/s_config.text .


Known Problems

  1. Trimming clips from the head may invalidate the Mocha track.
  2. Any S_Effect saved with an earlier version containing WarpDrops will render incorrectly after installing Sapphire 11. The effect can be fixed by clicking "Edit Effect" to open Builder, and then clicking "OK" to update the effect to Sapphire 11.
  3. Media Composer 7.04 or later is required for full Effect Builder support. On DS and older versions of Media Composer, S_Effect and S_Transition can load and edit effects, but will not display any parameters.

  4. If multiple copies of S_Effect or S_Transition are stacked on a clip, Media Composer may display the parameters of one or both effects incorrectly. This will hopefully be fixed in a future version of Media Composer.

  5. When dragging on-screen widgets to adjust a parameter, the image is not redrawn with the new values until you release the mouse. This is an AVX 2 limitation that will hopefully be fixed in future versions of Avid products.

  6. Avid plug-in processing is supported on fields only, for field-based media. They usually do not provide full frame data to plug-ins. For some effects such as warps, this can cause less vertical sharpness than you would get from the same effect on other platforms.

  7. In LensFlareAutoTrack the hotspot will move around if the resolution changes (including yellow/green to full green) and the hotspot_shift parameter is set to any value other than zero. If using the hotspot_shift parameter always work in full green mode.


To Sapphire Plug-ins Introduction


PRODUCT UPDATES & SPECIAL OFFERS

Join our email newsletter and keep up to date