Black Friday Sale - Up to 50% OFF all products - Sale limited to one product purchase

Sapphire 2019 for Adobe macOS

Download Now

The installer below is for use with all AE compatible products including After Effects and Premiere Pro.

To Download and install:

  1. Make sure you have one or more AE plug-in compatible applications on a Mac with an Intel CPU and MacOS 10.8 or greater.
  2. If you have an older version of Sapphire Plug-ins, the new installation will replace it, and you do not need to un-install it first.
  3. Quit AE or other host applications that may be running.
  4. Download the installer.
  5. Run the installer. When it asks for your passphrase, enter your macOS user login password, and follow the instructions given by the installer.
  6. Restart your host product, and the new plug-ins should appear in your effects menu.

To view on-line documentation after you install the software, go to the /Applications/GenArtsSapphireAE folder and double click on Online Help.html or Online Help.pdf. You can also click on the “About” box while using any plug-in.

In general, you can load projects saved with older Sapphire effects and they should automatically convert to use Sapphire v12. Please visit the support page for more info on this.

If you already installed Sapphire v12 and want to go back to an older version you should first uninstall v12.





This software may use the Qt user interface framework. Qt is distributed under the terms of the Lesser GNU Public License (LGPL), Version 2.1; see http://www.gnu.org/licenses/lgpl-2.1.html for more details. The source code for Qt is available here.